°æÈ¨ÉùÃ÷

CH341A编程器手册

 顶部 下一页

版权声明

CH341A编程器软件及本用户手册版权归枫叶在线所有。

产品的发行和销售由购买者在许可协议条款下使用。

未经枫叶在线允许，任何单位及个人不得将该产品全部或部分复制、照相、再生、翻译或还原成其它机器可读形式的电子媒介。

本手册若有任何改动恕不另行通知。

因软件版本升级而造成的与本手册内容不符，请以软件为准。


²úÆ·ÌØÐÔ

顶部 上一页 下一页

产品特性

应用领域:

1. 家电维修: 适合于家电维修行业刷写彩电、DVD、电脑主板、硬盘、路由上的存储芯片。

2. 产品研发: 公司产品研发过程中烧写测试芯片。

产品特点:

3. 自动识别芯片型号。

4. 自动选择芯片供电电压。

5. 全面支持25 FLASH、24 EEPROM等系列的存储芯片。

7. 支持MXIC系列的Secured OTP读写.

8. 支持Windows 2000、Windows XP、Windows Vista、Windows 7、Windows 8, 含32位 和 64位系统。

销售清单:

1. 编程器主机 1台

2. 产品烧写软件 驱动等 1份（邮箱发送或网络下载）

3. 简易贴片转接座 1个

4. 杜邦线 3根

Copyright 2010-2013 枫叶在线 版权所有 保留所有权利！


ÔËÐÐ»·¾³

运行环境

操作系统:

Windows 2000、Windows XP、Windows Vista、Windows 7、Windows 8, 含32位和64位系统。

硬件最小配置:

IBM-PC 586或奔腾兼容机，台式或手提电脑.

USB1.0标准的通用串行总线接口。

64M的RAM。

硬盘至少10M剩余空间。


Èí¼þ°²×°

软件安装

本软件纯绿色，免安装。

软件压缩包解压后双击软件所在目录中的CH341A.exe程序即可运行编程器软件。


Çý¶¯°²×°

驱动安装

注：安装驱动时先不要插入编程器

一.安装USB驱动(烧写24与25系列FLASH用到的驱动)。

1.双击如图

2.点击安装

3.如图点击确定就好了

二:安装TTL驱动(USB转串口,中九等支持串口在线下载的机型在线下载用)

1.双击如图

6. 点“安装”。

7. 如图点击确定就安装好了


Èí¼þ½çÃæ

1. 打开: 从文件加载数据到缓冲区。

2. 保存: 将缓冲区中数据保存到文件。

3. 填充: 将缓冲区填充指定的数据。

4. 交换: 将缓冲区中相邻的两个字节数据交换位置。

5. 自动: 自动完成擦除芯片、写芯片、校验芯片操作。

6. 擦除: 擦除芯片。

7. 写入: 将缓冲区中的数据写入到芯片。

8. 读取: 将芯片内的数据读到缓冲区。

9. 校验: 比较芯片和缓冲区中的数据是否相同。

10.检测: 自动检测芯片型号。

11.查空: 检查芯片是否为空白芯片。

12.终止: 停止软件工作。

13.帮助: 打开帮助文件。

14.关于: 显示编程器软件版本信息。


Ñ¡ÔñÐ¾Æ¬

选择芯片

用户可以从“类型”、“厂商”、“器件”下拉列表框中选择正确的芯片型号。

用户也可以点“芯片查找”按钮，在芯片查找对话框中选择正确的芯片型号。


¶ÁÈ¡Ð¾Æ¬

读取芯片

将芯片内的数据读到缓冲区中。


´ò¿ªÎÄ¼þ

打开文件

将文件中的数据加载到缓冲区。

支持的文件格式有*.bin和*.hex格式。

如果文件的长度大于当前所选择芯片的容量，那么超出部分会提示超出范围并被丢弃！


Ð´ÈëÐ¾Æ¬

写芯片

将缓冲区中的数据写入到芯片。


×Ô¶¯Íê³É

自动完成

本操作是一个组合操作，自动完成“擦除”、“查空”、“写入”、“校验”操作。


±£´æÎÄ¼þ

保存文件

将缓冲区中的数据保存到文件中。

支持的文件格式是二进制文件格式或Hex格式。


Ð§ÑéÐ¾Æ¬

校验芯片

比较芯片里的内容和软件的缓冲区中的数据是否相同。

在写芯片操作之后，校验芯片操作是必须的，可以保证写入数据的正确性！


²Á³ýÐ¾Æ¬

擦除芯片

25系列SPI FLASH芯片写入数据前必须先执行擦除操作。

24系列芯片写入数据前可不需要执行擦除操作。

25系列SPI FLASH芯片的擦除所花的时间因芯片而异，请耐心等待。


²éÕÒÐ¾Æ¬

查找芯片

用户点“芯片查找”按钮后弹出上面的查找对话框。

用户可以输入查找的关键字进行模糊查询，查询到的结果会显示在列表中。


×Ô¶¯¼ì²â

自动检测芯片型号

点点击软件的“检测”按钮后，编程器会自动识别出编程器上所放芯片的型号。会显示显示芯片的型号 容量 ID等信息。

使用本命令请注意以下几点：

2. 部分厂家的25系列SPI FLASH芯片识别命令比较特殊或无识别命令，这些厂家的芯片无法识别成功。

3. 同一厂家的多个相互兼容的芯片ID号可能相同，自动识别命令无法区分这些芯片，但不影响后续的读写操作。

如果出现上面的显示，不显示芯片的详细信息则表示检测失败，可能的原因有:

1. 芯片未放好或损坏。

3. 该芯片没有识别命令或识别命令特殊。


±à¼»º³åÇø

1. 缓冲区填充:

该命令将缓冲区中指定地址填充成特定数据。

“开始地址”表示要填充缓冲区的开始地址。

“结束地址”表示要填充缓冲区的结束地址。


Ð¾Æ¬ÁÐ±í

支持芯片

支持目前市场上几乎所有厂商的24，25系列芯片！

=====================25\26系列器件支持列表=====================

AMIC

A25L05P, A25L512, A25L10P, A25L010, A25L020, A25L20P, A25L40P, A25L040, A25L080, A25L80P, A25L16P, A25L016, A25L032

ATMEL

AT25F512, AT25F512B, AT25F512A, AT25F1024, AT25FS010, AT25F1024A, AT25F2048, AT25DF021, AT26F004, AT26DF041A, AT25FS040, AT25DF041A, AT25F4096, AT26DF081A, AT25DF161, AT26DF161, AT26DF161A, AT26DF321, AT25DF321A, AT25DF321, AT25DF641

COMMON

25X005, 25X05, 25X10, 25X20, 25X40, 25X80, 25X16, 25X32, 25X64, 25X128, 25X256, 25X512, 25X1024, 25X2048

EON

EN25B05T, EN25P05, EN25LF05, EN25B05, EN25F05, EN25P10, EN25F10, EN25LF10, EN25D10, EN25D20, EN25LF20, EN25F20, EN25LF40, EN25F40, EN25D40, EN25D80, EN25T80, EN25Q80, EN25P80, EN25F80, EN25Q16, EN25B16, EN25B16T, EN25D16, EN25T16, EN25H16, EN25F16, EN25B32, EN25Q32, EN25B32T, EN25F32, EN25P32, EN25Q64, EN25B64T, EN25B64, EN25F64, EN25QH128, EN25F128, EN25Q128

ES

ES25P10, ES25P20, ES25M40, ES25M40A, ES25P40, ES25M80A, ES25M80, ES25P80, ES25P16, ES25M16, ES25M16A, ES25P32

ESMT

F25L04UA, F25L004A, F25L08PA, F25L008A, F25L016A, F25L16PA, F25L32PA, F25L32QA, F25L64PA

GIGADEVICE

GD25Q512, GD25Q10, GD25Q20, GD25D40, GD25F40, GD25F80, GD25T80, GD25Q80, GD25D80, GD25Q16, GD25Q32, GD25Q64, GD25Q128

KH

KH25L4006E, KH25L8036D, KH25L8006E(OTP), KH25L1606E(OTP)

MSHINE

MS25X05, MS25X10, MS25X20, MS25X40, MS25X80, MS25X16, MS25X32, MS25X64, MS25X128

MXIC

MX25V512, MX25L512, MX25L1005, MX25L2005, MX25L2026, MX25U4035(OTP), MX25V4035, MX25L4005A, MX25V4005, MX25U8035(OTP), MX25L8006E(OTP), MX25V8006E, MX25V8005, MX25L8005, MX25U8033E, MX25L8036E, MX25V8035, MX25L8035E, MX25L1633E, MX25L1608D(OTP), MX25L1608E(OTP), MX25L1635E, MX25L1606E(OTP), MX25L1636D, MX25U1635E, MX25L1636E, MX25L1605D, MX25L3206E(OTP), MX25L3205D, MX25L3235D, MX25U3235F, MX25L3237D, MX25L3236D, MX25L3208E(OTP), MX25U3235E, MX25L3225D, MX25L3208D(OTP), MX25L6465E(OTP), MX25L6408E(OTP), MX25L6405D, MX25L6436E(OTP), MX25L6408D(OTP), MX25L6406E(OTP), MX25L6455E, MX25L6445E(OTP), MX25L12836E(OTP), MX25L12855E(OTP), MX25L12835E, MX25L12835F(OTP), MX25U12835F, MX25L12805D(OTP), MX25L12845E(OTP), MX25L12865E(OTP), MX25L25635E(OTP)

NEXFLASH

NX25P10, NX25P20, NX25P40, NX25P80, NX25P16, NX25P32

PMC

PM25LV512A, PM25LV010A, PM25LV020, PM25LV040, PM25LV080B, PM25LV016B

SAIFUN

SA25F005, SA25F010, SA25F020, SA25F040, SA25F080, SA25F160, SA25F320

SPANSION

S25FL001, S25FL004, S25FL040, S25FL002, S25FL008, S25FL160, S25FL016, S25FL032, S25FL064, S25FL129, S25FL128, S25FL256, S25FL512

SST

SST25VF512A, SST25VF512, SST25VF010A, SST25VF010, SST25VF020, SST25VF020A, SST25LF020A, SST25VF040A, SST25VF040B, SST25VF040, SST25VF080B, SST25VF016B, SST25VF032B, SST25VF064C

ST

M25P05A, M25PE10, M25P10A, M25PE20, M25P20 , M25P40, M25PE40, M25PX80, M25PE80, M25P80 , M25P16, M25PX16, M25PE16, M25P32, M25PE32, M25PX32, M25P64, M25PE64, M25PX64, M25P128

WINBOND

W25X10AL, W25P10, W25X10L, W25X10, W25X10A, W25X20A, W25X20L, W25X20, W25X20AL, W25P20 , W25Q40BV, W25X40AL, W25X40, W25X40L, W25P40 , W25X40A, W25X80L, W25Q80BV, W25Q80V, W25X80AL, W25X80, W25P80, W25X80A, W25X16, W25Q16BV, W25Q16V, W25P16, W25X32, W25Q32V, W25Q32BV, W25P32, W25Q64BV, W25X64, W25P64, W25Q128BV, W25Q256FV

=====================24系列器件支持列表=====================

ATMEL

AT24C01, AT24C01A, AT24C01B, AT24C02, AT24C02A, AT24C02B, AT24C04B, AT24C04, AT24C04A, AT24C08, AT24C08A, AT24C08B, AT24C16B, AT24C16, AT24C16A, AT24C32B, AT24C32A, AT24C32, AT24C64, AT24C64A, AT24C64B, AT24C128B, AT24C128, AT24C128A, AT24C256A, AT24C256, AT24C256B, AT24C512B, AT24C512A, AT24C512, AT24C1024, AT24C1024A, AT24C1024B

CATALYST

CAT24C01, CAT24WC01, CAT24C02, CAT24WC02, CAT24C04, CAT24WC04, CAT24WC08, CAT24C08, CAT24WC16, CAT24C16, CAT24WC32, CAT24C32, CAT24WC64, CAT24C64, CAT24C128, CAT24WC128, CAT24C256, CAT24WC256, CAT24C512, CAT24WC512, CAT24C1024, CAT24WC1024

COMMON

24C01 3V, 24C01 5V, 24C02 3V, 24C02 5V, 24C04 3V, 24C04 5V, 24C08 3V, 24C08 5V, 24C16 5V, 24C16 3V, 24C32 5V, 24C32 3V, 24C64 5V, 24C64 3V, 24C128 5V, 24C128 3V, 24C256 5V, 24C256 3V, 24C512 5V, 24C512 3V, 24C1024 3V, 24C1024 5V, 24C2048 5V, 24C2048 3V, 24C4096 5V, 24C4096 3V

FAIRCHILD

FM24C01L, FM24C02L, FM24C03L, FM24C05L, FM24C04L, FM24C08L, FM24C09L, FM24C17L, FM24C16L, FM24C32L, FM24C64L, FM24C128L, FM24C256L, FM24C512L, FM24C1

HOLTEK

HT24C01, HT24LC01, HT24LC02, HT24C02, HT24C04, HT24LC04, HT24C08, HT24LC08, HT24C16, HT24LC16, HT24LC32, HT24C32, HT24LC64, HT24C64, HT24C128, HT24LC128, HT24LC256, HT24C256, HT24LC512, HT24C512, HT24C1024, HT24LC1024

ISSI

IS24C01, IS24C02, IS24C04, IS24C08, IS24C16, IS24C32, IS24C64, IS24C128, IS24C256, IS24C512, IS24C1024

MICROCHIP

MIC24LC014, MIC24AA01, MIC24AA014, MIC24LC01B, MIC24LC02B, MIC24AA02, MIC24C02C, MIC24LC025, MIC24AA024, MIC24LC024, MIC24LC04B, MIC24AA025, MIC24AA04, MIC24LC08B, MIC24AA08, MIC24LC16B, MIC24AA16, MIC24LC32, MIC24AA32, MIC24LC64, MIC24AA64, MIC24FC64, MIC24FC128, MIC24AA128, MIC24LC128, MIC24AA256, MIC24LC256, MIC24FC256, MIC24AA512, MIC24LC512, MIC24FC512, MIC24AA1024

NSC

NSC24C02L, NSC24C02, NSC24C64

RAMTRON

FM24CL04, FM24C04A, FM24CL16, FM24C16A, FM24CL64, FM24C64, FM24C256, FM24CL256, FM24C512

ROHM

BR24L01, BR24C01, BR24L02, BR24C02, BR24L04, BR24C04, BR24L08, BR24C08, BR24L16, BR24C16, BR24L32, BR24C32, BR24C64, BR24L64

ST

ST24C01, ST24C02, ST24C04, ST24C08, ST24C16, ST24C32, ST24C64

XICOR

X24C01, X24C02, X24C04, X24C08, X24C16


ÔÚÏßË¢»ú

在线刷机

将编程器插到电脑USB口,编程器上的TX脚接到中九的RX,RX接到中九的TX,GND接到中九的GND.

选择好对应的COM口,打开对应平台的下载软件,即可在线升级你的中九机了.

（此类软件不是编程器附带的软件，我们不提供，需要可自行网上查找）


³£¼ûÎÊÌâ

常见问题解答

1. 向芯片写入数据后，校验不通过。

(1)写数据前要选择正确的芯片型号。

(2)如果是25系列FLASH芯片，写入数据前一定要先擦除。

(3)如果是24系列芯片，存储器单元有8bit和16bit之分，写数据前要确认实际芯片的存储单元宽度是否和所选芯片的存储单元宽度一致。

(4)存储芯片可能已经损坏。

2. 读写芯片时芯片放的位置。

(1)如果是读写25系列芯片，芯片放在下图中的位置.

(2)如果是读写24系列芯片，芯片放在下图中的位置.

3. 自动检测芯片型号不正确。

请查看“自动检测芯片型号”一节！

4. 简易贴片转接座的使用。

简易贴片转接座上有多个焊接贴片芯片的位置，两边各有1个16脚的可以焊接25系列16脚芯片，中间有3个8脚的可以焊接24 25系列芯片，8脚那边24 25系列宽体 窄体通用，使用时，可以任选一个位置使用，但不要同时焊接芯片。

、25系列宽体和窄体贴片器件。

5. 连接到主板在线刷BIOS芯片。

如果主板上的25系列BIOS芯片不便于取下来放到编程器读写，则可以将编程器直接连接到主板进行读写操作。

用户需要自制连接线，可以从转接座上将GND、CS、MISO、MOSI、CLK几根信号线引出并连接到主板。

需要主要的是，采用这种方式刷写BIOS芯片，需要主板的支持，否则可能会损坏编程器或主板。


Éý¼¶Ö§³Ö

升级支持

我们有可能对编程器软件不定期进行升级，请留意我们店铺商品页。

软件对正版用户开放, 可免费升级。

http://www.skygz.com

http://skygz.taobao.com

http://blog.163.com/skygz@126/